Membuat schedule Di mikrotik OS

Script dan Schedule di Mikrotik OS
By mujie ⋅ December 24, 2007 ⋅ Post a comment

Haha.. pas lagi searching pada rame topik tentang script dan schedule (penjadwalannya) di Mikrotik. Topik yang bagus buat naikin ini blog ke mister gugel. Lagian habis itu pada rame maen copy paste trus masukin di blog-nya masing-masing tanpa menyertakan sumber?!. Ada juga yang ironis mengklaim blog-nya dengan banner kecil bertuliskan “tidak sembarang copy paste”, padahal nyontek persis sama, wtf ! Mudahan bukan Anda.

Silahkan Anda copy tulisan saya jika ada yang ingin diambil, tidak perlu menyertakan sumber juga tidak apa-apa, tetapi jangan suka mengklaim yah🙂. Ok, kita lanjut! Disini saya akan memberikan contoh untuk menghidupkan dan mematikan koneksi pelanggan pada jam tertentu di Mikrotik Router OS.

Misalnya IP Address pelanggan yang telah kita set dan kita berikan src-nat IP publik (diasumsikan tidak melewati proxy) di Mikrotik adalah : 172.168.1.0/30

1. Login ke Mikrotik OS Anda, lalu ketik :

system script

2. Ketik script untuk mematikan koneksi pelanggan ke arah publik:

add name=”pelanggan-off”
policy=ftp,read,write,policy,winbox,password
source={/ip firewall nat set [/ip firewall nat find
src-address=172.168.1.0/30] disabled=yes}

3. Sedangkan script untuk menghidupkan koneksi pelanggan ke arah publik:

add name=”pelanggan-on”
policy=ftp,read,write,policy,winbox,password
source={/ip firewall nat set [/ip firewall nat find
src-address=172.168.1.0/30] disabled=no}

4. Lalu, langkah terakhir adalah menentukan jam kapan pelanggan harus terkoneksi ke publik (internet) atau mematikan IP publik pelanggan yang telah kita masukan kedalam script tadi. Misalnya kita tentukan jam hidup koneksi pada pukul 09.00-14.30, sedangkan waktu matinya koneksi pada pukul 14.31 – 08.59. Cukup kita panggil nama scriptnya didalam schedule :

.. scheduler

add name=hidup09-1430 start-time=09:00:00
interval=1d on-event=pelanggan-on

add name=mati1431-0859 start-time=14:31:00
interval=1d on-event=pelanggan-off

Beres🙂. Selamat mencoba bos!. Lebih jauh tentang Mikrotik scripting silahkan ke link berikut :

* http://wiki.mikrotik.com/wiki/Scripts
* http://www.mikrotik.com/
* http://www.mikrotik.co.id/

2 thoughts on “Membuat schedule Di mikrotik OS

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s